Degraded performance for Dashboard and Time Series data in US05

Incident Report for Braze, Inc.

Resolved

Braze Engineers have confirmed US05 cluster services continue to operate within normal operational bounds. Engineers will continue to monitor service health. This incident has been resolved.
Posted Sep 05, 2025 - 14:01 EDT

Monitoring

Braze Engineers are investigating an issue where customers might have experienced issues within the Dashboard and time series data not updating properly. Message sending and data processing were not impacted.

A fix has been implemented and we are monitoring the results.

Some customers may have experienced intermittent errors accessing the dashboard between approximately 12:15PM to 1:15PM EST.

In addition, some time series graphs may have experienced latency updating between approximately 1:00PM to 1:24PM.
Posted Sep 05, 2025 - 13:54 EDT
This incident affected: US 05 Cluster (Dashboard).