Delayed Support Services

Incident Report for Braze, Inc.

Resolved

The incident is resolved and our support services are now back to normal operations.
Posted Dec 03, 2023 - 06:13 EST

Identified

Due to an unexpected Salesforce outage, Braze is experiencing delays and disruptions in responses to Technical Support cases.

We are continuing to monitor and will provide an update once Salesforce is fully operational.
Posted Dec 03, 2023 - 03:57 EST
This incident affected: Global Services (Braze Support Services).