Issue impacting US01 and US05 clusters

Incident Report for Braze, Inc.

Resolved

We can confirm this incident is resolved and no further issues have been experienced since 13:21 ET.
Posted Sep 02, 2025 - 13:45 EDT

Monitoring

Between 13:08 ET to 13:21 users may have experienced an increase in latency and dashboard errors. We can confirm other services were not impacted by the issue.
Posted Sep 02, 2025 - 13:30 EDT

Identified

We're investigating an issue impacting services on the US01 and US05 clusters. A further update will be provided shortly.
Posted Sep 02, 2025 - 13:20 EDT
This incident affected: US 01 Cluster (Dashboard, SDK Data Collection, Data Processing, REST APIs, Outbound Messaging, Currents, Cloud Data-Ingestion (CDI)) and US 05 Cluster (Dashboard, SDK Data Collection, Data Processing, Rest APIs, Outbound Messaging, Currents, Cloud Data-Ingestion (CDI)).