Google Firebase incident causing Android Push Notification errors
Incident Report for Braze, Inc.
Resolved
Google Firebase has resolved the incident on their side. We can confirm that Braze is no longer seeing errors for those small numbers of previously affected push tokens.
Posted Oct 19, 2024 - 10:32 EDT
Identified
Google Firebase Cloud Messaging is experiencing an incident (https://status.firebase.google.com/incidents/PTWWAYPjkjPapM4qkGY2) which is affecting a small number of Android push notification sends.

Braze can confirm that we have seen a low level of Android push notification errors since 18:30 ET on October 14th, the start time of Firebase's incident. While our system implements a retry mechanism for failed message deliveries, we are observing a very small number of instances (0.01%) where the maximum number of retries is being exhausted, resulting in a small number of undelivered Push Notifications. As the Firebase incident continues, it may be the case that more Android push notifications become undelivered.

Our team has escalated this matter to Google Firebase Support with our named contact, and we're actively monitoring the situation while awaiting further updates. We'll provide additional information as soon as it becomes available.
Posted Oct 16, 2024 - 14:10 EDT
This incident affected: Global Messaging Channels (Push Notifications - Android).