Email sending delays for MailJet customers
Incident Report for Braze, Inc.
Resolved
MailJet has resolved the issue. Emails that were delayed will begin delivering and subsequent email deliveries will occur as expected.
Posted May 07, 2021 - 01:11 EDT
Identified
We have identified an issue affecting customers who deliver their email through MailJet resulting from an SSL misconfiguration on MailJet's API. We have escalated the issue to the MailJet support team. Braze will continue to retry emails from MailJet with exponential backoff while MailJet works to resolve this issue.

Braze customers who send email through MailJet will experience email sending delays while the MailJet team works to correct their SSL certificate.
Posted May 06, 2021 - 22:35 EDT
This incident affected: EU 01 Cluster (Outbound Messaging).