Latency and Errors on US07

Incident Report for Braze, Inc.

Resolved

The Dashboard has continue to remain stable and the issue is now resolved.
Posted Sep 02, 2026 - 06:09 EDT

Monitoring

Engineers have implemented a fix and the Dashboard has been stable for over 30 minutes. We are continuing to monitor the issue to ensure full resolution.
Posted Sep 02, 2026 - 05:36 EDT

Identified

We have identified the issue leading to intermittent dashboard errors and latency and engineers are working to resolve the issue.
Posted Sep 02, 2026 - 04:58 EDT

Investigating

Our Engineering team are investigating intermittent latency and errors on the US07 Dashboard.
Posted Sep 02, 2026 - 03:43 EDT
This incident affected: US 07 Cluster (Dashboard).