SMS Delivery Delays to Multiple Countries in Europe

Incident Report for Braze, Inc.

Resolved

Latency has returned to normal operational bounds and this incident is now resolved.

Twilio's Statuspage will continue to provide updates on the remaining impact to Romania, Serbia, Poland, Bosnia and Herzegovina, and Cabo Verde: https://status.twilio.com/incidents/shhrhbqxflt1
Posted May 08, 2026 - 08:36 EDT

Update

SMS sending delays have been resolved for the majority of countries and sending has returned to normal. SMS delivery delays continue to impact Romania, Serbia, Poland, Bosnia and Herzegovina, and Cabo Verde.

For real-time updates from Twilio, please refer to: https://status.twilio.com/incidents/shhrhbqxflt1
Posted May 08, 2026 - 07:46 EDT

Monitoring

Braze Engineers continue to monitor the ongoing SMS delivery delays affecting multiple networks across European countries. This remains an active Twilio incident, and our team is closely tracking their progress. Twilio has identified the cause and is actively working to resolve the issue. They state that delivery delays to multiple networks continue in Romania, Serbia, Poland, Bosnia and Herzegovina, and Cabo Verde.

The incident has been resolved, and latency has returned to normal in all other countries.

Braze's next update on the issue will be 10 UTC on 9 May 2026.

For real-time updates from Twilio, please refer to: https://status.twilio.com/incidents/shhrhbqxflt1
Posted May 07, 2026 - 20:44 EDT

Update

Braze Engineers continue to monitor the ongoing SMS delivery delays affecting multiple networks across European countries. This remains related to an active Twilio incident, and our team is closely tracking their progress.

Twilio has identified the cause and is actively working to resolve the issue. We will provide another update as soon as the situation changes.

For real-time updates from Twilio, please refer to: https://status.twilio.com/incidents/shhrhbqxflt1
Posted May 07, 2026 - 13:10 EDT

Identified

Braze Engineers have identified an issue causing SMS delivery delays across networks in multiple European countries.

Braze Engineers confirmed this is related to an ongoing Twilio incident:
https://status.twilio.com/incidents/shhrhbqxflt1

We expect to provide another update as soon as more information becomes available.
Posted May 07, 2026 - 09:19 EDT
This incident affected: Global Messaging Channels (SMS).