US05 Processing Latency

Incident Report for Braze, Inc.

Resolved

Latency and error rates have remained at normal levels for all services, post-implementation of our fix, and this incident is resolved.

We will continue to monitor the overall system health until AWS reports full recovery.

Please see https://health.aws.amazon.com/health/status for more details.
Posted May 08, 2026 - 01:47 EDT

Monitoring

We have implemented a fix to mitigate the impact of the ongoing AWS incident in Availability Zone (use1-az4) in the US-EAST-1 region.

At this point, latency and error rates have returned to normal levels for all services.

Additionally, AWS is reporting early signs of recovery. Please see https://health.aws.amazon.com/health/status for more details.
Posted May 08, 2026 - 01:32 EDT

Update

We are continuing to experience delays in Campaign & Canvas Processing, Data Processing, and Message Sending. Additionally, Dashboard navigation is intermittently erroring. We are continuing to work on a fix while we await updates from AWS.

Please see https://health.aws.amazon.com/health/status for more details.
Posted May 08, 2026 - 01:04 EDT

Identified

Starting at 11:45 PM ET, Braze customers on our US05 have been experiencing latency across campaign/canvas processing, data processing, and message sending due to an ongoing issue with an upstream provider (AWS).

We are working on a fix.

Please see https://health.aws.amazon.com/health/status for more details.
Posted May 08, 2026 - 00:35 EDT
This incident affected: US 05 Cluster (Dashboard, SDK Data Collection, Data Processing, Outbound Messaging).