Dashboard Latency and Errors on US07

Incident Report for Braze, Inc.

Resolved

This was a recurrence of an earlier issue impacting the Dashboard. A permanent fix has been implemented and the Dashboard has remained stable since. We are confident the issue is now fully resolved. We apologize for any impact.
Posted Sep 02, 2026 - 07:58 EDT

Identified

We are investigating intermittent errors and latency impacting the US07 Dashboard.
Posted Sep 02, 2026 - 07:30 EDT
This incident affected: US 07 Cluster (Dashboard).