Degraded performance in Outbound Messaging and Data Processing on EU01

Incident Report for Braze, Inc.

Resolved

Engineers have continuously been monitoring services, and they have remained stable. This issue is now considered fully resolved.
Posted Jul 30, 2025 - 11:19 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 30, 2025 - 11:18 EDT

Monitoring

We have identified degraded performance between 2:05 PM and 2:28 PM UTC, which impacted Outbound Messaging and Data Processing on the EU01 cluster. This issue is now resolved, and Engineers are continuing to monitor services.
Posted Jul 30, 2025 - 10:49 EDT
This incident affected: EU 01 Cluster (Data Processing, Outbound Messaging).