WhatsApp Degraded Performance

Incident Report for Braze, Inc.

Resolved

Meta has recovered from the earlier issue impacting WhatsApp services, and full service has now been restored. WhatsApp message delivery, Campaign and Canvas creation or modification using WhatsApp templates, and Audience sync to Facebook are all operating normally.
Posted Jun 12, 2026 - 14:13 EDT

Monitoring

Meta's services appear to be stabilizing. We are continuing to monitor the situation and will provide a further update once full service has been restored.
Posted Jun 12, 2026 - 12:52 EDT

Identified

Meta, a third-party, is currently experiencing an issue impacting WhatsApp services. During this time, WhatsApp messages may experience latency.

Campaign and Canvas creation or modification may experience errors and latency when utilizing WhatsApp templates.

Audience sync to Facebook may also experience errors and latency during this period.
Posted Jun 12, 2026 - 10:58 EDT
This incident affected: Global Messaging Channels (WhatsApp).