Braze Engineers have confirmed US clusters are operating within normal operational bounds. Engineers will continue to monitor service health across all US clusters. This incident has been resolved.
Posted Aug 21, 2025 - 16:05 EDT
Update
We are continuing to monitor for any further issues.
Posted Aug 21, 2025 - 15:54 EDT
Monitoring
Braze REST and SDK services in the US were affected by a Cloudflare incident, for which Cloudflare has recently implemented a fix: https://www.cloudflarestatus.com/incidents/d9n3g1vnxdd2. We can confirm resolution and are no longer seeing latency issues.
Customers may have experienced increased latency when making API calls. Error rates for these API services remained low despite the increased latency, with less than 0.02% failing due to a timeout.
As our documented best practices note, customers should retry REST API calls that returned a 50x error code. Our SDK API will automatically retry and process all events; no events were lost.
We will continue monitoring the situation and provide an update in 30 minutes.
Posted Aug 21, 2025 - 15:50 EDT
Update
Braze Engineers continue to investigate increased latency in the REST APIs and SDK Data Collection across all US clusters.
Posted Aug 21, 2025 - 15:23 EDT
Update
We are continuing to investigate this issue.
Posted Aug 21, 2025 - 15:16 EDT
Investigating
Braze Engineers are currently investigating increased latency in the REST APIs.
Posted Aug 21, 2025 - 15:15 EDT
This incident affected: US 01 Cluster (Dashboard, SDK Data Collection, REST APIs), US 02 Cluster (Dashboard, SDK Data Collection, REST APIs), US 03 Cluster (Dashboard, SDK Data Collection, REST APIs), US 04 Cluster (SDK Data Collection, REST APIs), US 06 Cluster (SDK Data Collection, REST APIs), US 08 Cluster (SDK Data Collection, Rest APIs), US 05 Cluster (SDK Data Collection, Rest APIs), US 07 Cluster (SDK Data Collection, REST APIs), and US 10 Cluster (SDK Data Collection, REST APIs).