Increased latency in Outbound Messaging for all clusters

Incident Report for Braze, Inc.

Resolved

Braze Engineers have confirmed outbound message latency and service performance is now operating normally and within normal operational bounds. Engineers will continue to monitor service health across all clusters.

This incident has been resolved.
Posted Oct 22, 2025 - 19:48 EDT

Monitoring

At approximately 5:09 PM EST, a recent change introduced increased latency in outbound messaging. A fix has been deployed, and service performance is rapidly returning to normal operating levels.

We will continue to monitor the system to ensure full resolution.
Posted Oct 22, 2025 - 19:19 EDT
This incident affected: Global Messaging Channels (Email, Push Notifications - iOS, Push Notifications - Android).