Snowflake has confirmed the incident they were experiencing is resolved. Braze can confirm all services are now healthy and working within normal operational bounds.
Posted Mar 19, 2025 - 17:49 EDT
Identified
Third-party Snowflake is currently experiencing an issue. As a result of this outage, customers may experience an impact on various functionalities within the Braze dashboard, including Query Builder, SQL Segments, Segment Extensions, Data Sharing configuration, and certain reporting features.
Customers integrating Snowflake with CDI or Currents may also experience latencies and errors during this time.
Posted Mar 19, 2025 - 14:53 EDT
This incident affected: US 01 Cluster (Dashboard, Currents, Cloud Data-Ingestion (CDI)), US 02 Cluster (Dashboard, Currents, Cloud Data-Ingestion (CDI)), US 03 Cluster (Dashboard, Currents, Cloud Data-Ingestion (CDI)), US 04 Cluster (Dashboard, Currents, Cloud Data-Ingestion (CDI)), US 06 Cluster (Dashboard, Currents, Cloud Data-Ingestion (CDI)), US 08 Cluster (Dashboard, Currents, Cloud Data-Ingestion (CDI)), US 05 Cluster (Dashboard, Currents, Cloud Data-Ingestion (CDI)), and US 07 Cluster (Dashboard, Currents, Cloud Data-Ingestion (CDI)).