Currents Delay in US
Incident Report for Braze, Inc.
Resolved
This incident has been resolved.
Posted 4 months ago. Sep 14, 2018 - 15:15 EDT
Identified
We identified the issue and are working on a fix.
Posted 4 months ago. Sep 14, 2018 - 14:32 EDT
Investigating
We are investigating currents delay for US customers.
Posted 4 months ago. Sep 14, 2018 - 14:18 EDT